読者です 読者をやめる 読者になる 読者になる

Ubuntu で nokogiri をインストールする

nokogiri をインストールしようとしたらエラーになったので対処方法を覚書。
gem から nokogiri をインストールしようとしたら以下のようにエラーになりました。

$ sudo gem install nokogiri
Building native extensions.  This could take a while...
ERROR:  Error installing nokogiri:
    ERROR: Failed to build gem native extension.
...

[ruby2.2-dev をインストールする]

わたしは ruby2.2 を使用しているんですが、ruby2.2-dev もインストールしておく必要があるみたい。

$ sudo atp-get install ruby2.2-dev
$ sudo gem install nokogiri
Building native extensions.  This could take a while...
Successfully installed nokogiri-1.6.6.2
1 gem installed

これで無事にインストール出来ました。

[参照]

Ubuntu14.04にNokogiriを導入する - Qiita